aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 5545cd673..8bff905f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,17 +52,13 @@ cstyle:
shellcheck:
@if type shellcheck > /dev/null 2>&1; then \
- shellcheck --exclude=SC1090 --format gcc scripts/paxcheck.sh \
+ shellcheck --exclude=SC1090 --format=gcc scripts/paxcheck.sh \
scripts/zloop.sh \
scripts/zfs-tests.sh \
scripts/zfs.sh \
- scripts/commitcheck.sh; \
- (find cmd/zed/zed.d/*.sh -type f) | \
- grep -v 'zfs-script-config' | \
- while read file; do \
- shellcheck --exclude=SC1090 --format gcc "$$file"; \
- done; \
- fi
+ scripts/commitcheck.sh \
+ $$(find cmd/zed/zed.d/*.sh -type f); \
+ fi
lint: cppcheck paxcheck