aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGiuseppe Di Natale <[email protected]>2017-04-06 17:16:41 -0700
committerBrian Behlendorf <[email protected]>2017-04-06 17:16:41 -0700
commit7469863167a111516303670d936ead4edec7026b (patch)
treee1e86a4456f77fdda2c8a8ec63394c1ad1567086 /Makefile.am
parentbbfd6354a893775f7f1456b2d91479716a507be0 (diff)
Correct shellcheck make recipe
Consolidated the shellcheck call in the make recipe down to a single call of shellcheck. Corrected script errors that have been skipped. Corrected script errors that have been introduced because make wasn't reporting any errors from shellcheck. Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Giuseppe Di Natale <[email protected]> Closes #5976
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 5545cd673..8bff905f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,17 +52,13 @@ cstyle:
shellcheck:
@if type shellcheck > /dev/null 2>&1; then \
- shellcheck --exclude=SC1090 --format gcc scripts/paxcheck.sh \
+ shellcheck --exclude=SC1090 --format=gcc scripts/paxcheck.sh \
scripts/zloop.sh \
scripts/zfs-tests.sh \
scripts/zfs.sh \
- scripts/commitcheck.sh; \
- (find cmd/zed/zed.d/*.sh -type f) | \
- grep -v 'zfs-script-config' | \
- while read file; do \
- shellcheck --exclude=SC1090 --format gcc "$$file"; \
- done; \
- fi
+ scripts/commitcheck.sh \
+ $$(find cmd/zed/zed.d/*.sh -type f); \
+ fi
lint: cppcheck paxcheck