aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/tests/graw/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-07-22 14:50:15 +0100
committerEric Engestrom <[email protected]>2019-08-03 00:08:37 +0000
commitd2d85b950d78c553b2694cda9ef0cc7bf9a0f737 (patch)
treeafdd28e30b66064b8b540a6e9d6d0ecbe27a6678 /src/gallium/tests/graw/meson.build
parent8ddb38209d51c53d6e5792b04b97814dfce9bce6 (diff)
meson: replace libmesa_util with idep_mesautil
This automates the include_directories and dependencies tracking so that all users of libmesa_util don't need to add them manually. Next commit will remove the ones that were only added for that reason. Signed-off-by: Eric Engestrom <[email protected]> Acked-by: Eric Anholt <[email protected]> Tested-by: Vinson Lee <[email protected]>
Diffstat (limited to 'src/gallium/tests/graw/meson.build')
-rw-r--r--src/gallium/tests/graw/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/gallium/tests/graw/meson.build b/src/gallium/tests/graw/meson.build
index fd416c16287..f8ed2bce3bc 100644
--- a/src/gallium/tests/graw/meson.build
+++ b/src/gallium/tests/graw/meson.build
@@ -30,7 +30,7 @@ foreach t : progs
'graw-' + t,
t + '.c',
include_directories : inc_common,
- link_with : [libgraw, libgraw_util, libmesa_util, libgallium],
- dependencies : [dep_m, dep_thread]
+ link_with : [libgraw, libgraw_util, libgallium],
+ dependencies : [dep_m, dep_thread, idep_mesautil],
)
endforeach