aboutsummaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-10-11 18:38:52 +0100
committerEric Engestrom <[email protected]>2019-07-10 11:27:51 +0000
commitc78d2d98409200f0b40d2e7bb7d143afbf1f0895 (patch)
tree58ddf5098168f1049c021a33580ecebc283ff2e2 /src/egl/meson.build
parentba18b968e8745119f66f293a9366c6708c4ed3b8 (diff)
egl: add glvnd symbols check
According to the spec [1], `__egl_Main` is the only symbol that needs to be exported. We don't want applications directly linking against libEGL_mesa.so (apps should always go through libEGL.so, regardless of who is providing it), so we shouldn't export any other symbols either. [1] https://github.com/NVIDIA/libglvnd/blob/master/include/glvnd/libeglabi.h (this header is the closest there is to a spec) Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 019f79ee212..d864c099efa 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -194,7 +194,7 @@ pkg.generate(
if with_tests and prog_nm.found()
if with_glvnd
- # TODO: add glvnd symbol check
+ egl_symbols = files('egl-glvnd-symbols.txt')
else
egl_symbols = files('egl-symbols.txt')
endif