aboutsummaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-11-22 18:44:29 +0000
committerEric Engestrom <[email protected]>2019-07-10 11:27:51 +0000
commitba18b968e8745119f66f293a9366c6708c4ed3b8 (patch)
tree710952bb25e0c5539b20d17599347f979b3eb979 /src/egl/meson.build
parentb619f89e238f0b4b101d9f57a3005f7ec7e70123 (diff)
egl: rewrite entrypoints check
Part of the effort to replace shell scripts with portable python scripts. I could've used a trivial `assert lines == sorted(lines)`, but this way the caller is shown which entrypoint is out of order. Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by Dylan Baker <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index a6b66a06857..019f79ee212 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -208,8 +208,8 @@ if with_tests and prog_nm.found()
suite : ['egl'],
)
test('egl-entrypoint-check',
- find_program('egl-entrypoint-check'),
- env : ['srcdir=' + meson.current_source_dir()],
+ prog_python,
+ args : files('egl-entrypoint-check.py', 'main/eglentrypoint.h'),
suite : ['egl'],
)
endif