aboutsummaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am38
1 files changed, 23 insertions, 15 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 0b58dd9f8..f85380f79 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -1,15 +1,23 @@
-# All headers are referenced by this top level Makefile.am and the
-# nobase_* rule is used to ensure all path information is preserved
-# when using the 'make install' target.
-nobase_include_HEADERS = *.h
-nobase_include_HEADERS += asm/*.h
-nobase_include_HEADERS += fs/*.h
-nobase_include_HEADERS += linux/*.h
-nobase_include_HEADERS += rpc/*.h
-nobase_include_HEADERS += sharefs/*.h
-nobase_include_HEADERS += sys/fm/*.h
-nobase_include_HEADERS += sys/fs/*.h
-nobase_include_HEADERS += sys/sysevent/*.h
-nobase_include_HEADERS += sys/*.h
-nobase_include_HEADERS += util/*.h
-nobase_include_HEADERS += vm/*.h
+# All headers are referenced by this top level Makefile.am are
+# noinst_HEADERS because they are not installed in the usual include
+# location. We do not want to be using $includedir for this.
+# Installation is handled by the custom install-data-local rule.
+noinst_HEADERS = *.h
+noinst_HEADERS += asm/*.h
+noinst_HEADERS += fs/*.h
+noinst_HEADERS += linux/*.h
+noinst_HEADERS += rpc/*.h
+noinst_HEADERS += sharefs/*.h
+noinst_HEADERS += sys/fm/*.h
+noinst_HEADERS += sys/fs/*.h
+noinst_HEADERS += sys/sysevent/*.h
+noinst_HEADERS += sys/*.h
+noinst_HEADERS += util/*.h
+noinst_HEADERS += vm/*.h
+
+install-data-local:
+ instdest=$(DESTDIR)/$(LINUX)/include/spl; \
+ instfiles=`find . -name '*.h'`; \
+ for instfile in $$instfiles; do \
+ $(INSTALL) -D $$instfile $$instdest/$$instfile; \
+ done