aboutsummaryrefslogtreecommitdiffstats
path: root/tests/zfs-tests/cmd/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2021-11-07 13:27:44 -0800
committerGitHub <[email protected]>2021-11-07 14:27:44 -0700
commitde198f2d9507b6dcf3d0d8f037ba33940208733e (patch)
tree79cc6e16cae7527aa51672da56f4cb026053f3bf /tests/zfs-tests/cmd/Makefile.am
parent4b87c1981d47655fd2eec2fb95179818240c4945 (diff)
Fix lseek(SEEK_DATA/SEEK_HOLE) mmap consistency
When using lseek(2) to report data/holes memory mapped regions of the file were ignored. This could result in incorrect results. To handle this zfs_holey_common() was updated to asynchronously writeback any dirty mmap(2) regions prior to reporting holes. Additionally, while not strictly required, the dn_struct_rwlock is now held over the dirty check to prevent the dnode structure from changing. This ensures that a clean dnode can't be dirtied before the data/hole is located. The range lock is now also taken to ensure the call cannot race with zfs_write(). Furthermore, the code was refactored to provide a dnode_is_dirty() helper function which checks the dnode for any dirty records to determine its dirtiness. Reviewed-by: Matthew Ahrens <[email protected]> Reviewed-by: Tony Hutter <[email protected]> Reviewed-by: Rich Ercolani <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Issue #11900 Closes #12724
Diffstat (limited to 'tests/zfs-tests/cmd/Makefile.am')
-rw-r--r--tests/zfs-tests/cmd/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/zfs-tests/cmd/Makefile.am b/tests/zfs-tests/cmd/Makefile.am
index 2b965ca70..d1c29fcd1 100644
--- a/tests/zfs-tests/cmd/Makefile.am
+++ b/tests/zfs-tests/cmd/Makefile.am
@@ -19,6 +19,7 @@ SUBDIRS = \
mktree \
mmap_exec \
mmap_libaio \
+ mmap_seek \
mmapwrite \
nvlist_to_lua \
randwritecomp \