aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libzpool/Makefile.am
diff options
context:
space:
mode:
authorAlejandro Colomar <[email protected]>2022-03-05 01:25:22 +0100
committerGitHub <[email protected]>2022-03-04 16:25:22 -0800
commitdb7f1a91def6bbaf72dd3e9ad31255efb0bf81ab (patch)
tree1817651092cca3f549bf229436993cb10736706d /lib/libzpool/Makefile.am
parent06b805067833902613de1871fa01e29fc80c8247 (diff)
Use _Noreturn (C11; GNU89) properly
A function that returns with no value is a different thing from a function that doesn't return at all. Those are two orthogonal concepts, commonly confused. pthread_create(3) expects a pointer to a start routine that has a very precise prototype: void *(*start_routine)(void *); However, other thread functions, such as kernel ones, expect: void (*start_routine)(void *); Providing a different one is incorrect, and has only been working because the ABIs happen to produce a compatible function. We should use '_Noreturn void', since it's the natural type, and then provide a '_Noreturn void *' wrapper for pthread functions. For consistency, replace most cases of __NORETURN or __attribute__((noreturn)) by _Noreturn. _Noreturn is understood by -std=gnu89, so it should be safe to use everywhere. Ref: https://github.com/openzfs/zfs/pull/13110#discussion_r808450136 Ref: https://software.codidact.com/posts/285972 Reviewed-by: Brian Behlendorf <[email protected]> Co-authored-by: Ahelenia ZiemiaƄska <[email protected]> Signed-off-by: Alejandro Colomar <[email protected]> Closes #13120
Diffstat (limited to 'lib/libzpool/Makefile.am')
-rw-r--r--lib/libzpool/Makefile.am5
1 files changed, 0 insertions, 5 deletions
diff --git a/lib/libzpool/Makefile.am b/lib/libzpool/Makefile.am
index 60ffbb7ee..e60a906a5 100644
--- a/lib/libzpool/Makefile.am
+++ b/lib/libzpool/Makefile.am
@@ -24,11 +24,6 @@ AM_CFLAGS += $(ZLIB_CFLAGS)
AM_CFLAGS += -DLIB_ZPOOL_BUILD
-# For the void (*)(void *) -> void *(*)(void *) cast in zk_thread_create()
-# See https://github.com/openzfs/zfs/pull/13110#discussion_r808450136
-kernel.$(OBJEXT): CFLAGS += $(NO_CAST_FUNCTION_TYPE)
-kernel.l$(OBJEXT): CFLAGS += $(NO_CAST_FUNCTION_TYPE)
-
lib_LTLIBRARIES = libzpool.la
USER_C = \