aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libuutil/Makefile.am
diff options
context:
space:
mode:
authorAntonio Russo <[email protected]>2020-11-14 21:35:31 -0700
committerBrian Behlendorf <[email protected]>2020-11-17 09:18:52 -0800
commit14c34c3d49319a0fea937d54167602c43ff9d93f (patch)
tree7ca38e771ad64cb64fcc1817e01a0029fe4f7639 /lib/libuutil/Makefile.am
parente6c59cd171bf141eae232db2f4c33ff79d5862c3 (diff)
Library ABI tracking with abigail
Provide two make targets: checkabi and storeabi. storeabi uses libabigail to generate a reference copy of the ABI for the public libraries. checkabi compares such a reference to the compiled version, failing if they are not compatible. No ABI is generated for libzpool.so, it is only used by ztest and zdb and not external consumers. Co-authored-by: Brian Behlendorf <[email protected]> Signed-off-by: Antonio Russo <[email protected]> Closes #11144
Diffstat (limited to 'lib/libuutil/Makefile.am')
-rw-r--r--lib/libuutil/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/libuutil/Makefile.am b/lib/libuutil/Makefile.am
index 4bce1609f..6f1fb4433 100644
--- a/lib/libuutil/Makefile.am
+++ b/lib/libuutil/Makefile.am
@@ -1,7 +1,10 @@
include $(top_srcdir)/config/Rules.am
+PHONY =
lib_LTLIBRARIES = libuutil.la
+include $(top_srcdir)/config/Abigail.am
+
USER_C = \
uu_alloc.c \
uu_avl.c \