aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libunicode/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2011-07-05 12:12:08 -0700
committerBrian Behlendorf <[email protected]>2011-07-06 09:20:28 -0700
commitb1c932d318ae604b6968ffef136952af4e80a407 (patch)
tree19c11a51798b06ebcf9b3cb6384c5ad93be89b6c /lib/libunicode/Makefile.am
parent8b0cf399ff9e764a08faea654bd30043a861cb09 (diff)
Add proper library versioning
The zfs libraries were never properly versioned. Since the API has remained static for quite some time this we never an issue. However, going forward they should be versioned. This commit versions all of the libraries to 1.0.0. From here on out this version must be updated to reflect changes to the library.
Diffstat (limited to 'lib/libunicode/Makefile.am')
-rw-r--r--lib/libunicode/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/libunicode/Makefile.am b/lib/libunicode/Makefile.am
index bdf0491dc..32be0529b 100644
--- a/lib/libunicode/Makefile.am
+++ b/lib/libunicode/Makefile.am
@@ -11,3 +11,5 @@ lib_LTLIBRARIES = libunicode.la
libunicode_la_SOURCES = \
$(top_srcdir)/module/unicode/u8_textprep.c \
$(top_srcdir)/module/unicode/uconv.c
+
+libunicode_la_LDFLAGS = -version-info 1:0:0