aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libspl/Makefile.am
diff options
context:
space:
mode:
authorKireinaHoro <[email protected]>2017-10-11 13:36:26 +0800
committerKireinaHoro <[email protected]>2017-10-12 01:36:16 +0800
commite102b1b51521f8444b5512796dca92e1c0518d1f (patch)
tree8426a0e271f31683c7d83a5250321be7728881ca /lib/libspl/Makefile.am
parenta7ec8c47e21c76624149beb1c9490c0e1bedf2a8 (diff)
Fix libspl assembler flags to respect cpu type
It's important to respect the user's CFLAGS as mismatched -mcpu will directly result in the assembler not able to produce correct code. Fixes #6733. Signed-off-by: Pengcheng Xu <[email protected]>
Diffstat (limited to 'lib/libspl/Makefile.am')
-rw-r--r--lib/libspl/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/libspl/Makefile.am b/lib/libspl/Makefile.am
index 28ae15351..7efadae8e 100644
--- a/lib/libspl/Makefile.am
+++ b/lib/libspl/Makefile.am
@@ -13,7 +13,8 @@ DEFAULT_INCLUDES += \
-I$(top_srcdir)/lib/libspl/include
AM_CCASFLAGS = \
- -I$(top_srcdir)/lib/libspl/include
+ -I$(top_srcdir)/lib/libspl/include \
+ $(CFLAGS)
noinst_LTLIBRARIES = libspl.la