aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libshare/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2021-06-03 23:50:07 +0200
committerBrian Behlendorf <[email protected]>2021-06-09 17:04:32 -0700
commit327c904615db9cfcd8c9e07cb56b8e36050a4048 (patch)
treeaee14f5621b8e6433d936d901803337a2364418c /lib/libshare/Makefile.am
parentd406a695c640dd93f49f8dcb532bfa0394ad1812 (diff)
lib{efi,avl,share,tpool,zfs_core,zfsbootenv,zutil}: -fvisibility=hidden
No symbols affected in libavl No symbols affected by libtpool, but pre-ANSI declarations got purged No symbols affected by libzfs_core No symbols affected by libzfs_bootenv libefi got cleaned, gained efi_debug documentation in efi_partition.h, and removes one undocumented and unused symbol from libzfs_core: D default_vtoc_map libnvpair saw removal of these symbols: D nv_alloc_nosleep_def D nv_alloc_sleep D nv_alloc_sleep_def D nv_fixed_ops_def D nvlist_hashtable_init_size D nvpair_max_recursion libshare saw removal of these symbols from libzfs: T libshare_nfs_init T libshare_smb_init T register_fstype B smb_shares libzutil saw removal of these internal symbols from libzfs_core: T label_paths T slice_cache_compare T zpool_find_import_blkid T zpool_open_func T zutil_alloc T zutil_strdup Reviewed-by: Matthew Ahrens <[email protected]> Reviewed-by: John Kennedy <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #12191
Diffstat (limited to 'lib/libshare/Makefile.am')
-rw-r--r--lib/libshare/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/libshare/Makefile.am b/lib/libshare/Makefile.am
index e42609c64..dff3e5382 100644
--- a/lib/libshare/Makefile.am
+++ b/lib/libshare/Makefile.am
@@ -2,6 +2,8 @@ include $(top_srcdir)/config/Rules.am
DEFAULT_INCLUDES += -I$(srcdir)
+AM_CFLAGS += -fvisibility=hidden
+
noinst_LTLIBRARIES = libshare.la
USER_C = \