aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libicp/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2020-01-17 12:40:09 -0800
committerGitHub <[email protected]>2020-01-17 12:40:09 -0800
commit70835c5b755e4fe1e16724e0a5d24e7e451f755c (patch)
tree9da58ece476b54ab6e0bda786f60c4da2dc2fc8d /lib/libicp/Makefile.am
parente5030fbc2846c347f58e3a0bae436da84b98ef16 (diff)
Unify target_cpu handling
Over the years several slightly different approaches were used in the Makefiles to determine the target architecture. This change updates both the build system and Makefile to handle this in a consistent fashion. TARGET_CPU is set to i386, x86_64, powerpc, aarch6 or sparc64 and made available in the Makefiles to be used as appropriate. Reviewed-by: Ryan Moeller <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Closes #9848
Diffstat (limited to 'lib/libicp/Makefile.am')
-rw-r--r--lib/libicp/Makefile.am17
1 files changed, 2 insertions, 15 deletions
diff --git a/lib/libicp/Makefile.am b/lib/libicp/Makefile.am
index 8b6c41771..02dfce22f 100644
--- a/lib/libicp/Makefile.am
+++ b/lib/libicp/Makefile.am
@@ -9,7 +9,7 @@ AM_CFLAGS += $(FRAME_LARGER_THAN)
noinst_LTLIBRARIES = libicp.la
-if TARGET_ASM_X86_64
+if TARGET_CPU_X86_64
ASM_SOURCES_C = asm-x86_64/aes/aeskey.c
ASM_SOURCES_AS = \
asm-x86_64/aes/aes_amd64.S \
@@ -18,22 +18,11 @@ ASM_SOURCES_AS = \
asm-x86_64/sha1/sha1-x86_64.S \
asm-x86_64/sha2/sha256_impl.S \
asm-x86_64/sha2/sha512_impl.S
-endif
-
-if TARGET_ASM_I386
-ASM_SOURCES_C =
-ASM_SOURCES_AS =
-endif
-
-if TARGET_ASM_GENERIC
+else
ASM_SOURCES_C =
ASM_SOURCES_AS =
endif
-USER_C =
-
-USER_ASM =
-
KERNEL_C = \
spi/kcf_spi.c \
api/kcf_ctxops.c \
@@ -78,8 +67,6 @@ KERNEL_C = \
KERNEL_ASM = $(ASM_SOURCES_AS)
nodist_libicp_la_SOURCES = \
- $(USER_C) \
- $(USER_ASM) \
$(KERNEL_C) \
$(KERNEL_ASM)