aboutsummaryrefslogtreecommitdiffstats
path: root/cmd/ztest/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2022-04-09 04:09:55 +0200
committerBrian Behlendorf <[email protected]>2022-05-10 10:18:38 -0700
commit5cdca5b1da7884c54260db473f892354bc79951b (patch)
tree6bdce13ac507fd450359dde2b3fa10405a480c54 /cmd/ztest/Makefile.am
parent3ff81c460114e0b3f69a9993d4777ec2c590fb16 (diff)
autoconf: use include directives instead of recursing down cmd
No installation diff, dist lost -zfs-2.1.99/cmd/fsck_zfs/fsck.zfs which was distributed erroneously, since it's generated Also clean gitrev on clean Also add -e 'any possible bashisms' to default checkbashisms flags, and fully parallelise it and shellcheck, and it works out-of-tree, too Also align the Release in the dist META file correctly Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #13316
Diffstat (limited to 'cmd/ztest/Makefile.am')
-rw-r--r--cmd/ztest/Makefile.am24
1 files changed, 9 insertions, 15 deletions
diff --git a/cmd/ztest/Makefile.am b/cmd/ztest/Makefile.am
index 353e81eb7..e27643a44 100644
--- a/cmd/ztest/Makefile.am
+++ b/cmd/ztest/Makefile.am
@@ -1,24 +1,18 @@
-include $(top_srcdir)/config/Rules.am
-
-AM_CFLAGS += $(KERNEL_CFLAGS)
-
+ztest_CFLAGS = $(AM_CFLAGS) $(KERNEL_CFLAGS)
# Get rid of compiler warning for unchecked truncating snprintfs on gcc 7.1.1
-AM_CFLAGS += $(NO_FORMAT_TRUNCATION)
-
-AM_CPPFLAGS += $(FORCEDEBUG_CPPFLAGS)
+ztest_CFLAGS += $(NO_FORMAT_TRUNCATION)
+ztest_CPPFLAGS = $(AM_CPPFLAGS) $(FORCEDEBUG_CPPFLAGS)
-sbin_PROGRAMS = ztest
+sbin_PROGRAMS += ztest
+CPPCHECKTARGETS += ztest
ztest_SOURCES = \
- ztest.c
+ %D%/ztest.c
ztest_LDADD = \
- $(abs_top_builddir)/libzpool.la \
- $(abs_top_builddir)/libzfs_core.la \
- $(abs_top_builddir)/libnvpair.la
+ libzpool.la \
+ libzfs_core.la \
+ libnvpair.la
ztest_LDADD += -lm
ztest_LDFLAGS = -pthread
-
-include $(top_srcdir)/config/CppCheck.am
-CPPCHECKTARGETS += ztest