aboutsummaryrefslogtreecommitdiffstats
path: root/cmd/ztest/Makefile.am
diff options
context:
space:
mode:
authorArvind Sankar <[email protected]>2020-07-06 16:01:29 -0400
committerBrian Behlendorf <[email protected]>2020-07-10 14:26:32 -0700
commit3e597dee1128db8907a2b757c675c41cfdbf21aa (patch)
tree4854f380b44a21feb9fb9e2dc0664da2d9868db1 /cmd/ztest/Makefile.am
parentaf6591622696bcb4e46702da07923e909db99f30 (diff)
Use abs_top_builddir when referencing libraries
libtool stores absolute paths in the dependency_libs component of the .la files. If the Makefile for a dependent library refers to the libraries by relative path, some libraries end up duplicated on the link command line. As an example, libzfs specifies libzfs_core, libnvpair and libuutil as dependencies to be linked in. The .la file for libzfs_core also specifies libnvpair, but using an absolute path, with the result that libnvpair is present twice in the linker command line for producing libzfs. While the only thing this causes is to slightly slow down the linking, we can avoid it by using absolute paths everywhere, including for convenience libraries just for consistency. Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Arvind Sankar <[email protected]> Closes #10538
Diffstat (limited to 'cmd/ztest/Makefile.am')
-rw-r--r--cmd/ztest/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/cmd/ztest/Makefile.am b/cmd/ztest/Makefile.am
index 4790e62ca..40d029d9f 100644
--- a/cmd/ztest/Makefile.am
+++ b/cmd/ztest/Makefile.am
@@ -15,9 +15,9 @@ ztest_SOURCES = \
ztest.c
ztest_LDADD = \
- $(top_builddir)/lib/libzpool/libzpool.la \
- $(top_builddir)/lib/libzfs_core/libzfs_core.la \
- $(top_builddir)/lib/libnvpair/libnvpair.la
+ $(abs_top_builddir)/lib/libzpool/libzpool.la \
+ $(abs_top_builddir)/lib/libzfs_core/libzfs_core.la \
+ $(abs_top_builddir)/lib/libnvpair/libnvpair.la
ztest_LDADD += -lm
ztest_LDFLAGS = -pthread