aboutsummaryrefslogtreecommitdiffstats
path: root/cmd/zed/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2021-04-19 07:13:24 +0200
committerGitHub <[email protected]>2021-04-18 22:13:24 -0700
commitfef8bd41fc178d7212957b611c9bc81fe10cb63e (patch)
tree3b3b31ae3fd5f1408f09bf547cb6d99767d6708b /cmd/zed/Makefile.am
parent50d9ff93dfdb5052e0466729d1d2e1e627a56080 (diff)
libspl: implement atomics in terms of atomics
This replaces the generic libspl atomic.c atomics implementation with one based on builtin gcc atomics. This functionality was added as an experimental feature in gcc 4.4. Today even CentOS 7 ships with gcc 4.8 as the default compiler we can make this the default. Furthermore, the builtin atomics are as good or better than our hand-rolled implementation so it's reasonable to drop that custom code. Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #11904
Diffstat (limited to 'cmd/zed/Makefile.am')
-rw-r--r--cmd/zed/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cmd/zed/Makefile.am b/cmd/zed/Makefile.am
index 7d2fe124f..884760415 100644
--- a/cmd/zed/Makefile.am
+++ b/cmd/zed/Makefile.am
@@ -43,7 +43,7 @@ zed_LDADD = \
$(abs_top_builddir)/lib/libnvpair/libnvpair.la \
$(abs_top_builddir)/lib/libuutil/libuutil.la
-zed_LDADD += -lrt $(LIBUDEV_LIBS) $(LIBUUID_LIBS)
+zed_LDADD += -lrt $(LIBATOMIC_LIBS) $(LIBUDEV_LIBS) $(LIBUUID_LIBS)
zed_LDFLAGS = -pthread
EXTRA_DIST = agents/README.md