aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2013-02-08 13:54:24 -0800
committerBrian Behlendorf <[email protected]>2013-03-01 16:55:06 -0800
commitfea77534f0a865bad1c7456bd9fceb1f54976988 (patch)
tree4e1090743ded91fe61f633cf2441722de54716b0 /Makefile.am
parent8adf71e9b0e20d9f1ec2b3bc308db206cb6ceed7 (diff)
Fix spl_config.h install permissions
The default permissions used by install are 755. Since this file isn't executable 644 is more appropriate. Signed-off-by: Brian Behlendorf <[email protected]>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 74c292093..1210c6d6b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,7 +34,7 @@ install-data-local:
release=$(SPL_META_VERSION)-$(SPL_META_RELEASE); \
instdest=$(DESTDIR)/usr/src/spl-$$release/$(LINUX_VERSION); \
for instfile in $(noinst_HEADERS) module/$(LINUX_SYMBOLS); do \
- $(INSTALL) -D $$instfile $$instdest/$$instfile; \
+ $(INSTALL) -m 644 -D $$instfile $$instdest/$$instfile; \
done
endif