aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Ercolani <[email protected]>2022-01-07 13:36:49 -0500
committerGitHub <[email protected]>2022-01-07 10:36:49 -0800
commitd6c1bbdd651654df781f5e5b67c31cb742c9c773 (patch)
treed81ae2182b7e83d600f7bee9923d5f9aff707d82 /Makefile.am
parent862d5dfc84ca06d1b3dba2dfe51c3f1ee2d4ad5f (diff)
Updated the lz4 decompressor
As an experiment, I stole the lz4 decompressor from upstream lz4 (1.9.3), and landed it. Feedback suggested that keeping the vendor lz4 code isolated and unlinted was probably reasonable, so I lobbed it into its own file. It also seemed reasonable to put the mostly-untouched* code into lz4.c proper, and relegate the integrated and ZFS-specific code to lz4_zfs.c. Reviewed-by: Matthew Ahrens <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Rich Ercolani <[email protected]> Closes #12805
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d4b75264d..37a9bfdf8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -126,6 +126,7 @@ cstyle:
! -name 'zfs_config.*' ! -name '*.mod.c' \
! -name 'opt_global.h' ! -name '*_if*.h' \
! -path './module/zstd/lib/*' \
+ ! -path './module/zfs/lz4.c' \
$(cstyle_line)
filter_executable = -exec test -x '{}' \; -print