aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGiuseppe Di Natale <[email protected]>2017-10-27 09:52:18 -0700
committerBrian Behlendorf <[email protected]>2017-10-27 09:52:18 -0700
commita94d38c0f382c16244912de83a7356ae35e63322 (patch)
tree5aa6f698a5e867f86cfb58ca028f40ce2b712ee3 /Makefile.am
parentee45fbd89465f12b39e97173a088175d4b712b5f (diff)
Correct make mancheck recipe
The current make recipe for mancheck silently ignores errors. Correct the recipe so errors cause the mancheck recipe fail. The zpool reopen command in the zpool.8 manpage had a bullet list without an .El. Reviewed-by: George Melikov <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: loli10K <[email protected]> Signed-off-by: Giuseppe Di Natale <[email protected]> Closes #6790
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index c51be2b4c..05cafc702 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -62,9 +62,10 @@ shellcheck:
mancheck:
@if type mandoc > /dev/null 2>&1; then \
- for file in zfs zpool zdb zgenhostid; do \
- mandoc -Tlint -Werror ${top_srcdir}/man/man8/$$file.8; \
- done \
+ find ${top_srcdir}/man/man8 -type f -name 'zfs.8' \
+ -o -name 'zpool.8' -o -name 'zdb.8' \
+ -o -name 'zgenhostid.8' | \
+ xargs mandoc -Tlint -Werror; \
fi
lint: cppcheck paxcheck