aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorbehlendo <behlendo@7e1ea52c-4ff2-0310-8f11-9dd32ca42a1c>2008-02-27 20:52:44 +0000
committerbehlendo <behlendo@7e1ea52c-4ff2-0310-8f11-9dd32ca42a1c>2008-02-27 20:52:44 +0000
commita0aadf5666d5070e55ab1a6fd58eddf06494010c (patch)
tree160a83c82b5dcf6e276cdf7a811b236d729458ef /Makefile.am
parent1735fa73f4ac6935e5029fbf5c3ce9e7c9617f8f (diff)
OK, everything builds now. My initial intent was to place all of
the directories at the top level but that proved troublesome. The kernel buildsystem and autoconf were conflicting too much. To resolve the issue I moved the kernel bits in to a modules directory which can then only use the kernel build system. We just pass along the likely make targets to the kernel build system. git-svn-id: https://outreach.scidac.gov/svn/spl/trunk@11 7e1ea52c-4ff2-0310-8f11-9dd32ca42a1c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7abb6ee39..1d219cd85 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,10 @@
AUTOMAKE_OPTIONS = foreign dist-zip
-SUBDIRS = src include scripts
+SUBDIRS = lib cmd modules include scripts
CONFIG_CLEAN_FILES = aclocal.m4 config.guess config.sub
CONFIG_CLEAN_FILES += depcomp install-sh missing mkinstalldirs
EXTRA_DIST = autogen.sh
rpms: dist Makefile
rpmbuild -ta $(distdir).tar.gz
+