aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2022-01-21 17:07:15 +0100
committerBrian Behlendorf <[email protected]>2022-01-26 11:38:52 -0800
commit7ada752a934f79d87fb9ef998455f26fd07f59a7 (patch)
treefadcb89e9710da5b7ad2d5b6f26c94eb1ca96d50 /Makefile.am
parenta3fecf4f1059f4afcead0e7a502ffe8babb1e39c (diff)
Clean up CSTYLEDs
69 CSTYLED BEGINs remain, appx. 30 of which can be removed if cstyle(1) had a useful policy regarding CALL(ARG1, ARG2, ARG3); above 2 lines. As it stands, it spits out *both* sysctl_os.c: 385: continuation line should be indented by 4 spaces sysctl_os.c: 385: indent by spaces instead of tabs which is very cool Another >10 could be fixed by removing "ulong" &al. handling. I don't foresee anyone actually using it intentionally (does it even exist in modern headers? why did it in the first place?). Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #12993
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 79f8ec07b..c8d1d08aa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -126,6 +126,8 @@ cstyle:
! -name 'zfs_config.*' ! -name '*.mod.c' \
! -name 'opt_global.h' ! -name '*_if*.h' \
! -path './module/zstd/lib/*' \
+ ! -path './include/sys/lua/*' \
+ ! -path './module/lua/l*.[ch]' \
! -path './module/zfs/lz4.c' \
$(cstyle_line)