aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2021-05-27 01:31:43 +0200
committerBrian Behlendorf <[email protected]>2021-06-04 12:48:26 -0700
commit4a98300feb783684a3adfba4959f7d7d26a4bd79 (patch)
tree704c2a5e89b44a63debf8f3c82711209974aa824 /Makefile.am
parent783784582225e8ddfbf07993d9fc278bf08025c5 (diff)
mancheck: accept lints, accept lint overrides
Reviewed-by: Richard Laager <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: Tony Nguyen <[email protected]> Reviewed-by: Ryan Moeller <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #12129
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 1 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e4fffc5d..4e7e29589 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -137,12 +137,7 @@ storeabi: lib
PHONY += mancheck
mancheck:
- @if type mandoc > /dev/null 2>&1; then \
- find ${top_srcdir}/man ${top_srcdir}/tests/test-runner/man -type f -name '*[1-9]*' \
- -exec mandoc -Tlint -Werror {} \+; \
- else \
- echo "skipping mancheck because mandoc is not installed"; \
- fi
+ ${top_srcdir}/scripts/mancheck.sh ${top_srcdir}/man ${top_srcdir}/tests/test-runner/man
if BUILD_LINUX
stat_fmt = -c '%A %n'