aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Yao <[email protected]>2014-08-29 11:53:09 -0400
committerBrian Behlendorf <[email protected]>2014-10-28 09:37:06 -0700
commit3cd33ffc3ba1ebbc90eab280d87d6ac096be92f9 (patch)
tree7266ac8315ac1e9b674429e2014175a217872691 /Makefile.am
parented6e9cc235b47b5c940178926715f871bd36dc5e (diff)
Kernel header installation should respect --prefix
This is the upstream component of work that enables preliminary support for building Gentoo's ZFS packaging on other Linux systems via Gentoo Prefix. Signed-off-by: Richard Yao <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Issue #2641
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5f0ee6453..49b417a81 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,10 +12,10 @@ endif
if CONFIG_KERNEL
SUBDIRS += module
-extradir = /usr/src/zfs-$(VERSION)
+extradir = @prefix@/src/zfs-$(VERSION)
extra_HEADERS = zfs.release.in zfs_config.h.in
-kerneldir = /usr/src/zfs-$(VERSION)/$(LINUX_VERSION)
+kerneldir = @prefix@/src/zfs-$(VERSION)/$(LINUX_VERSION)
nodist_kernel_HEADERS = zfs.release zfs_config.h module/$(LINUX_SYMBOLS)
endif