aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2013-12-17 16:11:57 -0800
committerBrian Behlendorf <[email protected]>2013-12-18 16:46:35 -0800
commit351a26ddc0a1ec85886fc961612f05686cce82e6 (patch)
tree24afed91546b7928e45aed00fa43322c7f5c79e2 /Makefile.am
parent2820bc49c5b7d63aa3941b8e173005f17dd0cee4 (diff)
cstyle: Exclude several files from 'make checkstyle'
The zfs_config.h header and *.mod.c files are both products of the build process. They must be excluded from the style check because they are not part of the pristine source. Signed-off-by: Brian Behlendorf <[email protected]> Issue #1821
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6c808b662..dfb006b75 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,7 +41,8 @@ dist-hook:
$(distdir)/META
checkstyle:
- find ${top_srcdir} -name '*.[hc]' -type f -exec scripts/cstyle.pl {} \;
+ @find ${top_srcdir} -name '*.[hc]' ! -name 'zfs_config.*' \
+ ! -name '*.mod.c' -type f -exec scripts/cstyle.pl {} \+
ctags:
$(RM) $(top_srcdir)/tags