aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorchrisrd <[email protected]>2018-02-22 07:35:59 +1100
committerBrian Behlendorf <[email protected]>2018-02-21 12:35:59 -0800
commit26cb4b87917f81e8fcb34070cccf57b83109c424 (patch)
treee87c1ce04263bd3252d0047c9d6d90889cc15181 /Makefile.am
parentfaa97c1619e5d7b51b2077db18fb92c5279b9db3 (diff)
Allow make checkstyle and paxscript in build dir
Reviewed-by: Giuseppe Di Natale <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: George Melikov <[email protected]> Signed-off-by: Chris Dunlop <[email protected]> Closes #7202
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 07d583fdf..90a1c9475 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,19 +45,20 @@ checkstyle: cstyle shellcheck flake8 commitcheck mancheck testscheck
commitcheck:
@if git rev-parse --git-dir > /dev/null 2>&1; then \
- scripts/commitcheck.sh; \
+ ${top_srcdir}/scripts/commitcheck.sh; \
fi
cstyle:
@find ${top_srcdir} -name '*.[hc]' ! -name 'zfs_config.*' \
- ! -name '*.mod.c' -type f -exec scripts/cstyle.pl -cpP {} \+
+ ! -name '*.mod.c' -type f \
+ -exec ${top_srcdir}/scripts/cstyle.pl -cpP {} \+
shellcheck:
@if type shellcheck > /dev/null 2>&1; then \
shellcheck --exclude=SC1090 --format=gcc \
- $$(find scripts/*.sh -type f) \
- $$(find cmd/zed/zed.d/*.sh -type f) \
- $$(find cmd/zpool/zpool.d/* -executable); \
+ $$(find ${top_srcdir}/scripts/*.sh -type f) \
+ $$(find ${top_srcdir}/cmd/zed/zed.d/*.sh -type f) \
+ $$(find ${top_srcdir}/cmd/zpool/zpool.d/* -executable); \
fi
mancheck:
@@ -88,7 +89,7 @@ cppcheck:
paxcheck:
@if type scanelf > /dev/null 2>&1; then \
- scripts/paxcheck.sh ${top_srcdir}; \
+ ${top_srcdir}/scripts/paxcheck.sh ${top_srcdir}; \
fi
flake8: