aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2022-04-09 18:35:53 +0200
committerBrian Behlendorf <[email protected]>2022-05-10 10:19:02 -0700
commit0a8b1fc6251af5d16d9f87ce696ec6f04edaba31 (patch)
treee0c4235a9093919b21fb25f3cd012e6a32859d67 /Makefile.am
parent09a7ad38a5407b5ac6c2a75f679504367655e471 (diff)
autoconf: use include directives instead of recursing down scripts
Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #13316
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 131066b4d..514439584 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,7 @@
CLEANFILES =
EXTRA_DIST =
INSTALL_DATA_HOOKS =
+ALL_LOCAL =
include $(top_srcdir)/config/Shellcheck.am
include $(top_srcdir)/config/Rules.am
@@ -16,7 +17,8 @@ endif
CPPCHECKDIRS += etc/systemd/system-generators
if CONFIG_USER
-SUBDIRS += scripts . man tests etc contrib
+SUBDIRS += . man tests etc contrib
+include $(srcdir)/%D%/scripts/Makefile.am
include $(srcdir)/%D%/lib/Makefile.am
include $(srcdir)/%D%/cmd/Makefile.am
if BUILD_LINUX
@@ -83,8 +85,8 @@ distclean-local:
-o -name '*.gcno' \) \
-type f -delete
-all-local:
- -SCRIPT_COMMON=$(top_builddir)/scripts/common.sh $(top_srcdir)/scripts/zfs-tests.sh -c
+PHONY += $(ALL_LOCAL)
+all-local: $(ALL_LOCAL)
dist-hook:
$(top_srcdir)/scripts/make_gitrev.sh -D $(distdir) $(GITREV)
@@ -122,7 +124,7 @@ cstyle:
filter_executable = -exec test -x '{}' \; -print
-SHELLCHECKDIRS = contrib etc scripts tests
+SHELLCHECKDIRS = contrib etc tests
SHELLCHECKSCRIPTS += autogen.sh
PHONY += mancheck