aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2010-07-28 13:59:18 -0700
committerBrian Behlendorf <[email protected]>2010-07-28 14:55:32 -0700
commit099dc9c2d275b4475f130f3d03bab88516101b36 (patch)
tree24827ed79b63e6de0a3af4e510b47d594d53230a /Makefile.am
parent287b2fb117f1ce964dc79c1f694e7d473a6b9db0 (diff)
Add uninstall Makefile targets
Extend the Makefiles with an uninstall target to cleanly remove a package which was installed with 'make install'. Additionally, ensure a 'depmod -a' is run as part of the install to update the module dependency information.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cae511de7..184c300cb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,7 +30,7 @@ distclean-local::
if CONFIG_KERNEL
install-data-local:
destname=spl-$(SPL_META_VERSION)/$(LINUX_VERSION); \
- instdest=$(DESTDIR)/${prefix}/src/$$destname; \
+ instdest=$(DESTDIR)/usr/src/$$destname; \
echo "${SPL_META_VERSION}" >$$instdest/spl.release; \
for instfile in $(noinst_HEADERS) module/$(LINUX_SYMBOLS); do \
$(INSTALL) -D $$instfile $$instdest/$$instfile; \