aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2022-04-10 02:46:19 +0200
committerBrian Behlendorf <[email protected]>2022-05-10 10:20:09 -0700
commit0425d58852a4b834b1813e0feb1a1ba6d5b72de8 (patch)
tree23cd4cf85b5e12a58dccab88f96544a0ffcde19f /Makefile.am
parent48f4379974d5b28bba9c22fcf3bab6ceb2844ff7 (diff)
autoconf: use include directives instead of recursing down tests (mostly)
Only down to tests/zfs-tests/tests, but pull out C programs into the main Makefile ‒ this means we get correct dependency tracking for all programs (and parallelise across them) dist diff: -zfs-2.1.99/tests/zfs-tests/tests/stress/ -zfs-2.1.99/tests/zfs-tests/tests/stress/Makefile.am -zfs-2.1.99/tests/zfs-tests/tests/stress/Makefile.in Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #13316
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e1d311c13..c474f905c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,13 +17,13 @@ include $(srcdir)/%D%/rpm/Makefile.am
endif
if CONFIG_USER
-SUBDIRS += . tests
include $(srcdir)/%D%/cmd/Makefile.am
include $(srcdir)/%D%/contrib/Makefile.am
include $(srcdir)/%D%/etc/Makefile.am
include $(srcdir)/%D%/lib/Makefile.am
include $(srcdir)/%D%/man/Makefile.am
include $(srcdir)/%D%/scripts/Makefile.am
+include $(srcdir)/%D%/tests/Makefile.am
if BUILD_LINUX
include $(srcdir)/%D%/udev/Makefile.am
endif
@@ -98,7 +98,6 @@ dist-hook:
PHONY += codecheck $(CHECKS)
codecheck: $(CHECKS)
-SHELLCHECKDIRS = tests
SHELLCHECKSCRIPTS += autogen.sh
PHONY += checkstyle