aboutsummaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/x11/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mesa/drivers/x11/Makefile.am')
-rw-r--r--src/mesa/drivers/x11/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/mesa/drivers/x11/Makefile.am b/src/mesa/drivers/x11/Makefile.am
index 27343d15791..4c63d59a57c 100644
--- a/src/mesa/drivers/x11/Makefile.am
+++ b/src/mesa/drivers/x11/Makefile.am
@@ -62,7 +62,8 @@ lib@GL_LIB@_la_LIBADD = \
$(GL_LIB_DEPS)
lib@GL_LIB@_la_LDFLAGS = \
+ -no-undefined \
-version-number $(GL_MAJOR):$(GL_MINOR):$(GL_PATCH) \
- -no-undefined
+ -Wl,--no-undefined
include $(top_srcdir)/install-lib-links.mk