aboutsummaryrefslogtreecommitdiffstats
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index ae296b92236..0aec2aa3daa 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -94,10 +94,14 @@ libglx_la_SOURCES = \
dri2_glx.c \
dri2.c \
dri2_query_renderer.c \
- dri3_glx.c \
- dri3_common.c \
applegl_glx.c
+if HAVE_DRI3
+libglx_la_SOURCES += \
+ dri3_glx.c \
+ dri3_common.c
+endif
+
GL_LIBS = \
libglx.la \
$(SHARED_GLAPI_LIBS) \