aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/omx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/omx/Makefile.am')
-rw-r--r--src/gallium/targets/omx/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/gallium/targets/omx/Makefile.am b/src/gallium/targets/omx/Makefile.am
index cd79a441b72..736ee0e7ada 100644
--- a/src/gallium/targets/omx/Makefile.am
+++ b/src/gallium/targets/omx/Makefile.am
@@ -43,6 +43,24 @@ STATIC_TARGET_LIB_DEPS += \
$(NOUVEAU_LIBS)
endif
+# Radeon winsys chaos
+if HAVE_GALLIUM_R600
+STATIC_TARGET_LIB_DEPS += \
+ $(top_builddir)/src/gallium/winsys/radeon/drm/libradeonwinsys.la
+endif
+
+if HAVE_GALLIUM_RADEON_COMMON
+STATIC_TARGET_LIB_DEPS += \
+ $(top_builddir)/src/gallium/drivers/radeon/libradeon.la
+endif
+
+if HAVE_GALLIUM_R600
+STATIC_TARGET_CPPFLAGS += -DGALLIUM_R600
+STATIC_TARGET_LIB_DEPS += \
+ $(top_builddir)/src/gallium/drivers/r600/libr600.la \
+ $(RADEON_LIBS)
+endif
+
libomx_mesa_la_SOURCES += target.c
libomx_mesa_la_CPPFLAGS = $(STATIC_TARGET_CPPFLAGS)
libomx_mesa_la_LIBADD += $(STATIC_TARGET_LIB_DEPS)