aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/radeonsi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/radeonsi/Makefile.am')
-rw-r--r--src/gallium/drivers/radeonsi/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/src/gallium/drivers/radeonsi/Makefile.am b/src/gallium/drivers/radeonsi/Makefile.am
index 7906fb6aa5f..595cf862744 100644
--- a/src/gallium/drivers/radeonsi/Makefile.am
+++ b/src/gallium/drivers/radeonsi/Makefile.am
@@ -23,7 +23,7 @@
include Makefile.sources
include $(top_srcdir)/src/gallium/Automake.inc
-noinst_LIBRARIES = libradeonsi.a
+noinst_LTLIBRARIES = libradeonsi.la
AM_CPPFLAGS = \
-I$(top_srcdir)/src/gallium/drivers/radeon \
@@ -32,10 +32,9 @@ AM_CPPFLAGS = \
$(GALLIUM_CFLAGS)
AM_CFLAGS = $(LLVM_CFLAGS)
-# This is a hack until we can move the backend into the LLVM project.
-# We need to use mklib, because it splits up libradeon.a into object files
-# so that we can link it with the radeonsi objects.
-libradeonsi_a_AR = $(top_srcdir)/bin/mklib -o radeonsi -static
+libradeonsi_la_SOURCES = $(C_SOURCES)
+libradeonsi_la_LIBADD = ../radeon/libllvmradeon@[email protected]
-libradeonsi_a_SOURCES = $(C_SOURCES)
-libradeonsi_a_LIBADD = ../radeon/libradeon.a
+#XXX: Delete this when all radeonsi targets are converted to automake.
+all-local: libradeonsi.la
+ ln -f $(builddir)/.libs/libradeonsi.a $(builddir)/libradeonsi.a