aboutsummaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index cf9320aecb2..abf60855737 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -174,11 +174,21 @@ libegl = shared_library(
version : egl_lib_version,
)
+# If using glvnd the pkg-config header should not point to EGL_mesa, it should
+# point to EGL. glvnd is only available on unix like platforms so adding -l
+# should be safe here
+# TODO: in the glvnd case glvnd itself should really be providing this.
+if with_glvnd
+ _egl = '-L${libdir} -lEGL'
+else
+ _egl = libegl
+endif
+
pkg.generate(
name : 'egl',
description : 'Mesa EGL Library',
version : meson.project_version(),
- libraries : libegl,
+ libraries : _egl,
libraries_private: gl_priv_libs,
requires_private : gl_priv_reqs,
extra_cflags : gl_pkgconfig_c_flags,