aboutsummaryrefslogtreecommitdiffstats
path: root/src/broadcom/drm-shim/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/broadcom/drm-shim/meson.build')
-rw-r--r--src/broadcom/drm-shim/meson.build62
1 files changed, 62 insertions, 0 deletions
diff --git a/src/broadcom/drm-shim/meson.build b/src/broadcom/drm-shim/meson.build
new file mode 100644
index 00000000000..2c2e4c5eb2e
--- /dev/null
+++ b/src/broadcom/drm-shim/meson.build
@@ -0,0 +1,62 @@
+# Copyright © 2019 Broadcom
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+libv3d_noop_drm_shim = shared_library(
+ ['v3d_noop_drm_shim'],
+ 'v3d_noop.c',
+ include_directories: inc_common,
+ dependencies: dep_drm_shim,
+ c_args : c_vis_args,
+ install : true,
+)
+
+dep_v3dv3 = dependency('v3dv3', required: false)
+if dep_v3dv3.found()
+ v3dv3_c_args = '-DUSE_V3D_SIMULATOR'
+
+ inc_gallium_v3d = include_directories('../../gallium/drivers/v3d')
+
+ per_version_libs = []
+ foreach ver : v3d_versions
+ per_version_libs += static_library(
+ 'libv3d_drm_shim-v' + ver,
+ [
+ 'v3dx.c',
+ v3d_xml_pack
+ ],
+ include_directories : [inc_common, inc_broadcom, inc_src, inc_gallium_v3d],
+ c_args : [c_vis_args, no_override_init_args, '-DV3D_VERSION=' + ver, v3dv3_c_args],
+ dependencies: [dep_valgrind, dep_thread, dep_v3dv3],
+ )
+ endforeach
+
+ libv3d_drm_shim = shared_library(
+ ['v3d_drm_shim'],
+ [
+ 'v3d.c',
+ '../../gallium/drivers/v3d/v3d_simulator_wrapper.cpp',
+ ],
+ dependencies: [dep_dl, dep_drm_shim, dep_v3dv3],
+ link_with: [libmesa_util, per_version_libs],
+ include_directories : [inc_common, inc_broadcom, inc_gallium_v3d],
+ c_args : [c_vis_args, no_override_init_args, '-std=gnu99', v3dv3_c_args],
+ cpp_args : [v3dv3_c_args]
+ )
+endif