aboutsummaryrefslogtreecommitdiffstats
path: root/src/vulkan/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2018-04-09 22:01:14 -0700
committerJason Ekstrand <[email protected]>2018-04-10 19:29:49 -0700
commit69f447553c6cd8c9004b80c099630ce7167a0a28 (patch)
tree3104813226eb78e98ddd07f2c22e3df1feb3d421 /src/vulkan/Makefile.am
parentae3a856c34e348f721c2d647999813801b5eb33c (diff)
vulkan: Drop vk_android_native_buffer.xml
All the information in vk_android_native_buffer.xml is now in vk.xml. The only exception is the extension type attribute which we can work around in the generators while we wait for the XML to be fixed. Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/vulkan/Makefile.am')
-rw-r--r--src/vulkan/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/vulkan/Makefile.am b/src/vulkan/Makefile.am
index bbcf7d0cc64..3da03ed09e1 100644
--- a/src/vulkan/Makefile.am
+++ b/src/vulkan/Makefile.am
@@ -4,13 +4,11 @@ noinst_LTLIBRARIES = libvulkan_wsi.la libvulkan_util.la
vulkan_includedir = $(includedir)/vulkan
vulkan_api_xml = $(top_srcdir)/src/vulkan/registry/vk.xml
-vk_android_native_buffer_xml = $(top_srcdir)/src/vulkan/registry/vk_android_native_buffer.xml
MKDIR_GEN = $(AM_V_at)$(MKDIR_P) $(@D)
PYTHON_GEN = $(AM_V_GEN)$(PYTHON2) $(PYTHON_FLAGS)
EXTRA_DIST = \
- $(top_srcdir)/include/vulkan/vk_android_native_buffer.h \
util/gen_enum_to_str.py \
util/meson.build \
wsi/meson.build \
@@ -21,11 +19,10 @@ VULKAN_UTIL_SOURCES = \
$(VULKAN_UTIL_GENERATED_FILES)
util/vk_enum_to_str.c util/vk_enum_to_str.h: util/gen_enum_to_str.py \
- $(vulkan_api_xml) $(vk_android_native_buffer_xml)
+ $(vulkan_api_xml)
$(MKDIR_GEN)
$(PYTHON_GEN) $(srcdir)/util/gen_enum_to_str.py \
--xml $(vulkan_api_xml) \
- --xml $(vk_android_native_buffer_xml) \
--outdir $(top_builddir)/src/vulkan/util
libvulkan_util_la_SOURCES = $(VULKAN_UTIL_SOURCES)