aboutsummaryrefslogtreecommitdiffstats
path: root/src/util/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-05-22 16:37:10 +0100
committerEric Engestrom <[email protected]>2019-06-27 17:42:25 +0000
commit53f17c4efdcded0283087ccc9777b31010db2fec (patch)
tree0e7aee26152fd66c076821024e47f07886c03d00 /src/util/meson.build
parentad0ee5bfa5b9cd6c0e867443b44f98079ff7e7ec (diff)
meson: set up a proper internal dependency for xmlconfig
Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/util/meson.build')
-rw-r--r--src/util/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/util/meson.build b/src/util/meson.build
index 23f8c68c701..67b6981d8b5 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -158,6 +158,13 @@ libxmlconfig = static_library(
build_by_default : false,
)
+idep_xmlconfig = declare_dependency(
+ sources : xmlpool_options_h,
+ include_directories : inc_util,
+ link_with : libxmlconfig,
+ dependencies : dep_expat,
+)
+
if with_tests
test(
'u_atomic',