aboutsummaryrefslogtreecommitdiffstats
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2019-04-08 12:44:17 -0700
committerDylan Baker <[email protected]>2019-04-15 13:44:29 -0700
commit95aefc94a941701616fda0776a3bd15710c8c151 (patch)
treebced9cf424ee7eb0cf753503eaace7cec4f62b50 /src/util/Makefile.am
parentde0c97c8171f8a8183b94d8ac6997117c4671da8 (diff)
Delete autotools
Acked-by: Kenneth Graunke <[email protected]> Reviewed-by: Eric Anholt <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Acked-by: Marek Olšák <[email protected]> Acked-by: Jason Ekstrand <[email protected]> Acked-by: Bas Nieuwenhuizen <[email protected]> Acked-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am101
1 files changed, 0 insertions, 101 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
deleted file mode 100644
index 4bda54c551d..00000000000
--- a/src/util/Makefile.am
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright © 2014 Intel Corporation
-#
-# Permission is hereby granted, free of charge, to any person obtaining a
-# copy of this software and associated documentation files (the "Software"),
-# to deal in the Software without restriction, including without limitation
-# the rights to use, copy, modify, merge, publish, distribute, sublicense,
-# and/or sell copies of the Software, and to permit persons to whom the
-# Software is furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice (including the next
-# paragraph) shall be included in all copies or substantial portions of the
-# Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
-# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
-# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
-# IN THE SOFTWARE.
-
-SUBDIRS = . \
- xmlpool \
- tests/fast_idiv_by_const \
- tests/hash_table \
- tests/string_buffer \
- tests/set
-
-if HAVE_STD_CXX11
-SUBDIRS += tests/vma
-endif
-
-include Makefile.sources
-
-noinst_LTLIBRARIES = \
- libmesautil.la \
- libxmlconfig.la
-
-AM_CPPFLAGS = \
- $(PTHREAD_CFLAGS) \
- -I$(top_srcdir)/include
-
-libmesautil_la_CPPFLAGS = \
- $(DEFINES) \
- -I$(top_srcdir)/include \
- -I$(top_srcdir)/src \
- -I$(top_srcdir)/src/mapi \
- -I$(top_srcdir)/src/mesa \
- -I$(top_srcdir)/src/gallium/include \
- -I$(top_srcdir)/src/gallium/auxiliary \
- $(VISIBILITY_CFLAGS) \
- $(MSVC2013_COMPAT_CFLAGS) \
- $(ZLIB_CFLAGS)
-
-libmesautil_la_SOURCES = \
- $(MESA_UTIL_FILES) \
- $(MESA_UTIL_GENERATED_FILES)
-
-libmesautil_la_LIBADD = \
- $(PTHREAD_LIBS) \
- $(CLOCK_LIB) \
- $(ZLIB_LIBS) \
- $(LIBATOMIC_LIBS) \
- -lm
-
-libxmlconfig_la_SOURCES = $(XMLCONFIG_FILES)
-libxmlconfig_la_CFLAGS = \
- $(DEFINES) \
- -I$(top_srcdir)/include \
- -I$(top_srcdir)/src \
- -DSYSCONFDIR=\"$(sysconfdir)\" \
- -DDATADIR=\"$(datadir)\" \
- $(VISIBILITY_CFLAGS) \
- $(EXPAT_CFLAGS)
-libxmlconfig_la_LIBADD = $(EXPAT_LIBS) -lm
-
-drircdir = $(datadir)/drirc.d
-drirc_DATA = 00-mesa-defaults.conf
-
-u_atomic_test_LDADD = libmesautil.la
-roundeven_test_LDADD = -lm
-mesa_sha1_test_LDADD = libmesautil.la
-
-check_PROGRAMS = u_atomic_test roundeven_test mesa-sha1_test
-TESTS = $(check_PROGRAMS)
-
-BUILT_SOURCES = $(MESA_UTIL_GENERATED_FILES)
-CLEANFILES = $(BUILT_SOURCES)
-EXTRA_DIST = \
- 00-mesa-defaults.conf \
- format_srgb.py \
- merge_driinfo.py \
- SConscript \
- xmlpool.h \
- sha1/README \
- meson.build
-
-PYTHON_GEN = $(AM_V_GEN)$(PYTHON) $(PYTHON_FLAGS)
-
-format_srgb.c: format_srgb.py
- $(PYTHON_GEN) $(srcdir)/format_srgb.py > $@