aboutsummaryrefslogtreecommitdiffstats
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-08-05 15:31:54 +0100
committerEmil Velikov <[email protected]>2014-08-08 19:23:25 +0100
commit16826a36efcae53b1eb606efd2ce9d05b84cac4c (patch)
treeee7956bd9ec9ddb210a07bc2e94ff6259d070d08 /src/util/Makefile.am
parent549229631849c0caa6826f2eb1170909f5e21c33 (diff)
util: remove ralloc_test
The tests in an empty stub, which we're currently building twice. If anyone is interested in expanding it (adding actual tests) they can always bring it back. Suggested-by: Kenneth Graunke <[email protected]> Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am30
1 files changed, 5 insertions, 25 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index e738ab08d2f..4733a1a74c5 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -19,14 +19,10 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
# IN THE SOFTWARE.
-SUBDIRS = . tests
+SUBDIRS = . tests/hash_table
include Makefile.sources
-BUILT_SOURCES = $(MESA_UTIL_GENERATED_FILES)
-
-CLEANFILES = $(BUILT_SOURCES)
-
noinst_LTLIBRARIES = libmesautil.la
libmesautil_la_CPPFLAGS = \
@@ -36,26 +32,10 @@ libmesautil_la_CPPFLAGS = \
libmesautil_la_SOURCES = \
$(MESA_UTIL_FILES) \
- $(MESA_UTIL_GENERATED_FILES)
+ $(MESA_UTIL_GENERATED_FILES)
+
+BUILT_SOURCES = $(MESA_UTIL_GENERATED_FILES)
+CLEANFILES = $(BUILT_SOURCES)
format_srgb.c: $(srcdir)/format_srgb.py
$(AM_V_GEN) $(PYTHON2) $< > $@
-
-### Tests:
-
-CFLAGS_FOR_TESTS = $(PTHREAD_CFLAGS)
-CPPFLAGS_FOR_TESTS = \
- $(libmesautil_la_CPPFLAGS) \
- -I$(top_srcdir)/src/gtest/include
-LDADD_FOR_TESTS = \
- $(top_builddir)/src/gtest/libgtest.la \
- $(top_builddir)/src/util/libmesautil.la \
- $(PTHREAD_LIBS)
-
-TESTS = tests/ralloc_test
-check_PROGRAMS = $(TESTS)
-
-tests_ralloc_test_SOURCES = tests/ralloc_test.cpp
-tests_ralloc_test_CFLAGS = $(CFLAGS_FOR_TESTS)
-tests_ralloc_test_CPPFLAGS = $(CPPFLAGS_FOR_TESTS)
-tests_ralloc_test_LDADD = $(LDADD_FOR_TESTS)