aboutsummaryrefslogtreecommitdiffstats
path: root/src/panfrost/meson.build
diff options
context:
space:
mode:
authorAlyssa Rosenzweig <[email protected]>2020-03-24 13:24:03 -0400
committerMarge Bot <[email protected]>2020-03-31 01:12:26 +0000
commitfd18695a2697bf54cf11894959780c2c761a1808 (patch)
tree4ad2497c129eb281e694c4c4bf8d65ebc9eb7243 /src/panfrost/meson.build
parent0f65f00a0dc438350454ba247b453cf80271a671 (diff)
pan/bit: Link standalone compiler with en/decoder
We would like to submit jobs from the standalone compiler for testing purposes, so let's get things wired up. Signed-off-by: Alyssa Rosenzweig <[email protected]> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4382>
Diffstat (limited to 'src/panfrost/meson.build')
-rw-r--r--src/panfrost/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/panfrost/meson.build b/src/panfrost/meson.build
index 41a5ade5725..e94a3341fb0 100644
--- a/src/panfrost/meson.build
+++ b/src/panfrost/meson.build
@@ -36,6 +36,7 @@ subdir('encoder')
files_bifrost = files(
'bifrost/cmdline.c',
+ 'bifrost/test/bi_submit.c'
)
bifrost_compiler = executable(
@@ -49,14 +50,18 @@ bifrost_compiler = executable(
inc_include,
inc_src,
inc_panfrost,
+ inc_panfrost_hw,
],
dependencies : [
idep_nir,
idep_mesautil,
+ dep_libdrm,
],
link_with : [
libglsl_standalone,
- libpanfrost_bifrost
+ libpanfrost_bifrost,
+ libpanfrost_decode,
+ libpanfrost_encoder,
],
build_by_default : true
)