aboutsummaryrefslogtreecommitdiffstats
path: root/src/panfrost/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-07-22 14:50:15 +0100
committerEric Engestrom <[email protected]>2019-08-03 00:08:37 +0000
commitd2d85b950d78c553b2694cda9ef0cc7bf9a0f737 (patch)
treeafdd28e30b66064b8b540a6e9d6d0ecbe27a6678 /src/panfrost/meson.build
parent8ddb38209d51c53d6e5792b04b97814dfce9bce6 (diff)
meson: replace libmesa_util with idep_mesautil
This automates the include_directories and dependencies tracking so that all users of libmesa_util don't need to add them manually. Next commit will remove the ones that were only added for that reason. Signed-off-by: Eric Engestrom <[email protected]> Acked-by: Eric Anholt <[email protected]> Tested-by: Vinson Lee <[email protected]>
Diffstat (limited to 'src/panfrost/meson.build')
-rw-r--r--src/panfrost/meson.build8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/panfrost/meson.build b/src/panfrost/meson.build
index 9c12ff8fd8e..435c64d354a 100644
--- a/src/panfrost/meson.build
+++ b/src/panfrost/meson.build
@@ -49,9 +49,7 @@ pandecode = executable(
include_directories : [inc_common, inc_include, inc_src, inc_panfrost],
dependencies : [
dep_thread,
- ],
- link_with : [
- libmesa_util
+ idep_mesautil,
],
build_by_default : true
)
@@ -71,11 +69,11 @@ bifrost_compiler = executable(
],
dependencies : [
dep_thread,
- idep_nir
+ idep_nir,
+ idep_mesautil,
],
link_with : [
libglsl_standalone,
- libmesa_util,
libpanfrost_bifrost
],
build_by_default : true