aboutsummaryrefslogtreecommitdiffstats
path: root/src/mesa/state_tracker/tests/Makefile.am
diff options
context:
space:
mode:
authorGert Wollny <[email protected]>2017-09-13 15:03:34 +0200
committerEmil Velikov <[email protected]>2017-09-15 13:56:28 +0100
commitc75d78161046f34350467b53054ff4e9da7a5cdd (patch)
tree4cb225cb1ef4b5429bdacf85fbb358807b02ff2c /src/mesa/state_tracker/tests/Makefile.am
parent3c5fb7346fb6f6863b7bc775cf1cf720b4fc5748 (diff)
mesa/st/tests: Correct build flags and force -std=c++11
Include src/gallium/Automake.inc, correct the build flags accordingly. Force -std=c++11 (extensively used by the test) as otherwise it gets defined only when building against llvm >= 3.9. Fixes: 7be6d8fe12 ("mesa/st: glsl_to_tgsi: add tests for the new temporary lifetime tracker") Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=102665 Reviewed-by: Emil Velikov <[email protected]> (v1)
Diffstat (limited to 'src/mesa/state_tracker/tests/Makefile.am')
-rw-r--r--src/mesa/state_tracker/tests/Makefile.am14
1 files changed, 5 insertions, 9 deletions
diff --git a/src/mesa/state_tracker/tests/Makefile.am b/src/mesa/state_tracker/tests/Makefile.am
index cd610e0adfa..f32957608e7 100644
--- a/src/mesa/state_tracker/tests/Makefile.am
+++ b/src/mesa/state_tracker/tests/Makefile.am
@@ -1,18 +1,17 @@
+include $(top_srcdir)/src/gallium/Automake.inc
+
AM_CFLAGS = \
$(PTHREAD_CFLAGS)
AM_CXXFLAGS = \
- $(LLVM_CXXFLAGS)
+ $(GALLIUM_DRIVER_CXXFLAGS) \
+ -std=c++11
AM_CPPFLAGS = \
-I$(top_srcdir)/src/gtest/include \
- -I$(top_srcdir)/src \
-I$(top_srcdir)/src/mapi \
-I$(top_builddir)/src/mesa \
-I$(top_srcdir)/src/mesa \
- -I$(top_srcdir)/include \
- -I$(top_srcdir)/src/gallium/include \
- -I$(top_srcdir)/src/gallium/auxiliary \
-I$(top_builddir)/src/compiler/glsl \
$(DEFINES)
@@ -32,7 +31,4 @@ st_renumerate_test_LDADD = \
$(top_builddir)/src/util/libmesautil.la \
$(top_builddir)/src/gtest/libgtest.la \
$(GALLIUM_COMMON_LIB_DEPS) \
- $(LIBUNWIND_LIBS) \
- $(LLVM_LIBS) \
- $(PTHREAD_LIBS) \
- $(DLOPEN_LIBS)
+ $(LLVM_LIBS)