aboutsummaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-04-16 14:40:51 -0700
committerDylan Baker <[email protected]>2018-04-24 14:08:15 -0700
commit595021bf1a67346c7dfca652ef2dbcce3e2a6ca0 (patch)
tree5e5f7b11473e99e1714690d398b8d417a6a05538 /src/mesa/drivers/dri/meson.build
parentdb90c8627c41486056aeef9883ef0e4a5f245441 (diff)
meson: remove dummy_cpp
meson has gotten pretty smart about tracking C and C++ dependencies (internal and external), and using the right linker. This wasn't always the case and we created empty c++ files to force the use of the c++ linker. We don't need that any more. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/mesa/drivers/dri/meson.build')
-rw-r--r--src/mesa/drivers/dri/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/mesa/drivers/dri/meson.build b/src/mesa/drivers/dri/meson.build
index 8e23fd43ad6..943727b662a 100644
--- a/src/mesa/drivers/dri/meson.build
+++ b/src/mesa/drivers/dri/meson.build
@@ -44,7 +44,7 @@ endif
if dri_drivers != []
libmesa_dri_drivers = shared_library(
'mesa_dri_drivers',
- dummy_cpp, # see meson #2180
+ [],
link_whole : dri_drivers,
link_with : [
libmegadriver_stub, libdricommon, libxmlconfig, libglapi, libmesa_util,