aboutsummaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/i965/Makefile.am
diff options
context:
space:
mode:
authorJonathan Gray <[email protected]>2017-03-16 13:49:36 +1100
committerEmil Velikov <[email protected]>2017-03-16 13:55:23 +0000
commitd2bb0c859062a3bc6ec92b4df7940375cc616b13 (patch)
tree1d5e148a029bee81ed95f96dbfdb6c47dfac58d9 /src/mesa/drivers/dri/i965/Makefile.am
parentccb89e72aa177ee5f95a8f5985e5aab037bd2aa7 (diff)
i965: avoid using a GNU make pattern rule
% pattern rules are a GNU extension. As there is only one file here avoid patterns and globbing entirely to fix the build on non-GNU make. Signed-off-by: Jonathan Gray <[email protected]> v2 [Emil Velikov: brw_oa.py dependency] Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/mesa/drivers/dri/i965/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i965/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/mesa/drivers/dri/i965/Makefile.am b/src/mesa/drivers/dri/i965/Makefile.am
index a83e3a6fa16..08391411eb6 100644
--- a/src/mesa/drivers/dri/i965/Makefile.am
+++ b/src/mesa/drivers/dri/i965/Makefile.am
@@ -92,8 +92,8 @@ EXTRA_DIST = \
# .c and .h files in one go so we don't hit problems with parallel
# make and multiple invocations of the same script trying to write
# to the same files.
-brw_oa_%.h: brw_oa_%.xml brw_oa.py Makefile.am
- $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/brw_oa.py --header=$(builddir)/brw_oa_$(*).h --chipset="$(*)" $(srcdir)/brw_oa_$(*).xml
-brw_oa_%.c: brw_oa_%.xml brw_oa.py Makefile.am
- $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/brw_oa.py --code=$(builddir)/brw_oa_$(*).c --chipset="$(*)" $(srcdir)/brw_oa_$(*).xml
+brw_oa_hsw.h: brw_oa.py brw_oa_hsw.xml
+ $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/brw_oa.py --header=$(builddir)/brw_oa_hsw.h --chipset=hsw $(srcdir)/brw_oa_hsw.xml
+brw_oa_hsw.c: brw_oa.py brw_oa_hsw.xml
+ $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/brw_oa.py --code=$(builddir)/brw_oa_hsw.c --chipset=hsw $(srcdir)/brw_oa_hsw.xml