aboutsummaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/i915/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-01-14 21:57:32 -0500
committerMatt Turner <[email protected]>2012-01-20 15:54:08 -0500
commit3c87dfce403ad3c2fed7998b16bea34dcb0c9fde (patch)
tree116233e49e5b73e3e44fd0844be8626a1eef2b74 /src/mesa/drivers/dri/i915/Makefile.am
parentc60dcc49e443eb1442b8f191e63078f2558eec31 (diff)
automake: src/mesa/drivers/dri/i915
Diffstat (limited to 'src/mesa/drivers/dri/i915/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i915/Makefile.am63
1 files changed, 63 insertions, 0 deletions
diff --git a/src/mesa/drivers/dri/i915/Makefile.am b/src/mesa/drivers/dri/i915/Makefile.am
new file mode 100644
index 00000000000..6bc7061f1e0
--- /dev/null
+++ b/src/mesa/drivers/dri/i915/Makefile.am
@@ -0,0 +1,63 @@
+
+
+# Copyright © 2012 Matt Turner <[email protected]>
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+# IN THE SOFTWARE.
+
+include Makefile.sources
+
+# Hack to make some of the non-automake variables work.
+TOP=$(top_builddir)
+
+AM_CFLAGS = \
+ -DI915 \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src/ \
+ -I$(top_srcdir)/src/mapi \
+ -I$(top_srcdir)/src/mesa/ \
+ -I$(top_srcdir)/src/mesa/drivers/dri/common \
+ -I$(top_srcdir)/src/mesa/drivers/dri/intel \
+ -I$(top_srcdir)/src/mesa/drivers/dri/intel/server \
+ $(DEFINES) \
+ $(ASM_FLAGS) \
+ $(API_DEFINES) \
+ $(INTEL_CFLAGS)
+
+dridir = $(DRI_DRIVER_INSTALL_DIR)
+
+if HAVE_I915_DRI
+dri_LTLIBRARIES = i915_dri.la
+endif
+
+i915_dri_la_SOURCES = \
+ $(i915_C_FILES) \
+ $(i915_CXX_FILES)
+
+i915_dri_la_LDFLAGS = -module -avoid-version -shared
+i915_dri_la_LIBADD = \
+ $(DRI_LIB_DEPS) \
+ $(DRICORE_LIB_DEPS) \
+ $(INTEL_LIBS)
+
+# Provide compatibility with scripts for the old Mesa build system for
+# a while by putting a link to the driver into /lib of the build tree.
+all-local: i915_dri.la
+ $(MKDIR_P) $(top_builddir)/$(LIB_DIR);
+ ln -f .libs/i915_dri.so $(top_builddir)/$(LIB_DIR)/i915_dri.so;