aboutsummaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2014-12-17 19:46:22 -0800
committerMatt Turner <[email protected]>2015-01-23 14:28:43 -0800
commitce98519266f735a2308eeae393d1facaaf174fd3 (patch)
tree1e30e2fa22e2bfa8033e69722ee0c94917e32c0e /src/mesa/Makefile.am
parent618c3b35f186ac547da078d39e85b42528916a5b (diff)
mesa: Drop inclusion of glapi_gen.mk.
Some glapi headers used to be generated from this Makefile.am, but no longer.
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index ac142fd33b9..8e7ef0bc7e4 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -55,10 +55,6 @@ $(BUILDDIR)main/git_sha1.h: $(BUILDDIR)main/git_sha1.h.tmp
rm main/git_sha1.h.tmp ;\
fi
-# include glapi_gen.mk for generating glapi headers for GLES
-GLAPI = $(top_srcdir)/src/mapi/glapi/gen
-include $(GLAPI)/glapi_gen.mk
-
BUILDDIR = $(builddir)/
include Makefile.sources
@@ -96,7 +92,7 @@ CLEANFILES = \
GET_HASH_GEN = main/get_hash_generator.py
-main/get_hash.h: $(GLAPI)/gl_and_es_API.xml main/get_hash_params.py \
+main/get_hash.h: ../mapi/glapi/gen/gl_and_es_API.xml main/get_hash_params.py \
$(GET_HASH_GEN) Makefile
$(AM_V_GEN)set -e; \
$(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/$(GET_HASH_GEN) \