aboutsummaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorChuck Atkins <[email protected]>2016-04-18 10:09:17 -0400
committerEmil Velikov <[email protected]>2016-05-01 08:37:25 +0100
commita92910ae37878b441ecb1c488f0a40d80a48f6fe (patch)
tree6617be94e6ecd180595625fb8c9b286428fa04e9 /src/mesa/Makefile.am
parentcbcd7b60f573d027337a2390e67f6010e9992aaa (diff)
glx: Refactor the configure options for glx implementation choice (v3)
Instead of cascading support for various different implementations of GLX, all three options are now specified through the --enable-glx option: --enable-glx=dri : Enable the DRI-based GLX --enable-glx=xlib : Enable the classic Xlib-based GLX --enable-glx=gallium-xlib : Enable the gallium Xlib-based GLX --enable-glx[=yes] : Defaults to dri if DRI is enabled, else gallium-xlib if gallium is enabled, else xlib This removes the --enable-xlib-glx option and fixes a bug in which both the classic xlib-glx and gallium xlib-glx implementations were getting built causing different versioned and conflicting libGL libraries to be installed. v2: Changes from various review feedback from Emil: a) Fixed typos b) Corrected help docs for new option c) Added appropriate a-b and r-b tags in commit msg d) Fixed various GLX related dependency checks. v3: Rebased to current master and added changelog in commit msg Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=94086 Acked-by: Brian Paul <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index 390381828e9..2c77fa80a49 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -21,7 +21,7 @@
SUBDIRS = . main/tests
-if HAVE_X11_DRIVER
+if HAVE_XLIB_GLX
SUBDIRS += drivers/x11
endif