aboutsummaryrefslogtreecommitdiffstats
path: root/src/mapi/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-04 16:11:34 -0700
committerDylan Baker <[email protected]>2017-10-09 13:42:43 -0700
commitfc48ad24272799b154de37f6a944eb391bdbbb82 (patch)
tree9c94ee0d22fc88d53703012b35c01680cbcac3d6 /src/mapi/Makefile.am
parent1b1bb6ee103a79de11aa4941ccbcd34f0a158276 (diff)
make: Fix test to be meson compatible
This has the same problem as the previous commit, generated headers and hardcoded paths. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/mapi/Makefile.am')
-rw-r--r--src/mapi/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mapi/Makefile.am b/src/mapi/Makefile.am
index 83e32d2185e..3febe27d74f 100644
--- a/src/mapi/Makefile.am
+++ b/src/mapi/Makefile.am
@@ -85,6 +85,7 @@ check_PROGRAMS += shared-glapi-test
shared_glapi_test_SOURCES = shared-glapi/tests/check_table.cpp
shared_glapi_test_CPPFLAGS = \
$(AM_CPPFLAGS) \
+ -I$(top_builddir)/src/mapi/glapi \
-I$(top_srcdir)/src/gtest/include
shared_glapi_test_LDADD = \
$(top_builddir)/src/mapi/shared-glapi/libglapi.la \
@@ -148,6 +149,7 @@ check_PROGRAMS += glapi-test
glapi_test_SOURCES = glapi/tests/check_table.cpp
glapi_test_CPPFLAGS = \
$(AM_CPPFLAGS) \
+ -I$(top_builddir)/src/mapi/glapi \
-I$(top_srcdir)/src/gtest/include
glapi_test_LDADD = \