aboutsummaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/meson.build
diff options
context:
space:
mode:
authorBas Nieuwenhuizen <[email protected]>2019-07-08 12:47:14 +0200
committerBas Nieuwenhuizen <[email protected]>2019-07-15 15:23:43 +0000
commitd4f0f1a6e21953a9bedc91f1de4366afdc51bb58 (patch)
tree9007dde4199bb536b2f9eae7d6e34b41a6b77ada /src/intel/vulkan/meson.build
parent0b8300580726a2299815582a33b488b6edd91c19 (diff)
anv: Add android dependencies on android.
Specifically needed for nativewindow for some VK_EXT_external_memory_android_hardware_buffers functions, where we call into some AHardwareBuffer functions. The legacy Android ext did not have us call into any Android function at all and hence it was not noticed. Fixes: 755c633b8d9 "anv: Fix vulkan build in meson." Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Chad Versace <[email protected]>
Diffstat (limited to 'src/intel/vulkan/meson.build')
-rw-r--r--src/intel/vulkan/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/intel/vulkan/meson.build b/src/intel/vulkan/meson.build
index 68695013c4c..ac80b2649b7 100644
--- a/src/intel/vulkan/meson.build
+++ b/src/intel/vulkan/meson.build
@@ -177,6 +177,7 @@ if with_xlib_lease
endif
if with_platform_android
+ anv_deps += dep_android
anv_flags += '-DVK_USE_PLATFORM_ANDROID_KHR'
libanv_files += files('anv_android.c')
else