aboutsummaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/meson.build
diff options
context:
space:
mode:
authorRafael Antognolli <[email protected]>2018-12-07 16:46:37 -0800
committerRafael Antognolli <[email protected]>2019-01-17 15:08:26 -0800
commit927ba12b53c90ebd8a2c4e3806d1052e7d604ded (patch)
treec23411f92a16dbebdf5443d1e1d80af09d4eae5a /src/intel/vulkan/meson.build
parent731c4adcf9b11d07e36e915ac17936259648c0c9 (diff)
anv/tests: Adding test for the state_pool padding.
Add a test that checks that we can use the extra space allocated for padding while allocating larger anv_states. Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/intel/vulkan/meson.build')
-rw-r--r--src/intel/vulkan/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/intel/vulkan/meson.build b/src/intel/vulkan/meson.build
index 15da828ca80..05fdeca8c25 100644
--- a/src/intel/vulkan/meson.build
+++ b/src/intel/vulkan/meson.build
@@ -227,7 +227,8 @@ if with_tests
)
foreach t : ['block_pool_no_free', 'state_pool_no_free',
- 'state_pool_free_list_only', 'state_pool']
+ 'state_pool_free_list_only', 'state_pool',
+ 'state_pool_padding']
test(
'anv_@0@'.format(t),
executable(