aboutsummaryrefslogtreecommitdiffstats
path: root/src/intel/tools/meson.build
diff options
context:
space:
mode:
authorKenneth Graunke <[email protected]>2018-05-01 17:27:08 -0700
committerKenneth Graunke <[email protected]>2018-05-02 09:27:56 -0700
commit7c22c150c40b3e2da892604d21c749aaec0b3cfd (patch)
tree441b1953cdf4be16f52dcf2bb3f31b90b037df16 /src/intel/tools/meson.build
parent5c049718318bfd9957aaa8f232d40286e101f02f (diff)
intel: Move batch decoder/disassembler from tools/ to common/
Making these part of libintel_common allows us to use them in the DRI driver. The standalone tool binaries already link against the common library, too, so it's no harder for them. Reviewed-by: Lionel Landwerlin <[email protected]>
Diffstat (limited to 'src/intel/tools/meson.build')
-rw-r--r--src/intel/tools/meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/intel/tools/meson.build b/src/intel/tools/meson.build
index e19de5af882..0be530546c3 100644
--- a/src/intel/tools/meson.build
+++ b/src/intel/tools/meson.build
@@ -20,8 +20,7 @@
aubinator = executable(
'aubinator',
- files('aubinator.c', 'disasm.c', 'gen_batch_decoder.c',
- 'gen_disasm.h', 'intel_aub.h'),
+ files('aubinator.c', 'intel_aub.h'),
dependencies : [dep_expat, dep_zlib, dep_dl, dep_thread, dep_m],
include_directories : [inc_common, inc_intel],
link_with : [libintel_common, libintel_compiler, libintel_dev, libmesa_util],
@@ -32,8 +31,7 @@ aubinator = executable(
aubinator_error_decode = executable(
'aubinator_error_decode',
- files('aubinator_error_decode.c', 'disasm.c', 'gen_disasm.h',
- 'gen_batch_decoder.c'),
+ files('aubinator_error_decode.c'),
dependencies : [dep_zlib, dep_thread],
include_directories : [inc_common, inc_intel],
link_with : [libintel_common, libintel_compiler, libintel_dev, libmesa_util],